Материал просмотрен 1,161 раз(а)

Всем привет! Сегодня я хочу предложить вам решить лёгкую задачку на устранение неполадок VTP (Vlan Trunking Protocol).

Схема сети:

Топология

Топология

Скачать схему можно отсюда: Бдымс! (Искренне надеюсь, что схема откроется. У меня 6.0.2.0052).

Стартап-конфиг SW1:

Развернуть »

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
switchport access vlan 10
!
interface FastEthernet0/6
switchport access vlan 20
!
interface FastEthernet0/7
switchport access vlan 20
!
interface FastEthernet0/8
switchport access vlan 20
!
interface FastEthernet0/9
switchport access vlan 20
!
interface FastEthernet0/10
switchport access vlan 20
!
interface FastEthernet0/11
switchport access vlan 50
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

 

Стартап-конфиг SW2:

Развернуть »

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

 

Стартап-конфиг SW3:

Развернуть »

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW3
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/2
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 30
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Итак, начинающий системный администратор Пётр Петрович соединил три коммутатора в кольцо и хочет убедиться, что протокол VTP работает как надо. Для проверки обновления базы VLAN на коммутаторах он создал на SW1 несколько VLAN (10, 20, 50) и ждёт, что они распространятся на остальные коммутаторы.

Попутно он зачем-то сделал VLAN 30 на коммутаторе SW3.

Вопреки его ожиданиям, VLAN-ы не распространяются на соседние устройства.

Помогите Петру Петровичу решить все проблемы в этой топологии.


Попутные вопросы:

  1. Где хранятся конфигурации протокола VTP?
  2. Почему VLAN-ы не распространились с коммутатора SW1 на устройство SW2?
  3. Почему VLAN-ы не распространились с коммутатора SW1 на устройство SW3?
  4. Почему VLAN-ы не распространились с коммутатора SW3 на коммутатор SW2?
  5. Что произойдёт с VLAN 30 на устройстве SW3, когда все проблемы в сети будут решены?

Я не буду спрашивать “Хотите ли вы ещё видеть подобные TroubleShoot-задачки?”, потому что в комментах всё равно почти никто не пишет 🙂

Всем бобра.

А вот и ответы!

Развернуть »

  1. Где хранятся конфигурации протокола VTP?
    Конфигурация VTP сохраняется в файле flash:vlan.dat на коммутаторе; В конфиге эти настройки не отображаются.
  2. Почему VLAN-ы не распространились с коммутатора SW1 на устройство SW2?
    Потому что между SW1 и SW2 нет trunk канала. Это видно из конфига соответствующих портов. Нужно добавить команды (config-if)# switchport mode trunk  для SW1:fa0/1 и SW2:fa0/1
  3. Почему VLAN-ы не распространились с коммутатора SW1 на устройство SW3?
    Потому что в SW3 настроен VTP домен с другим именем (LitlAdmin) против litladmin у остальных. Нужно поменять имя домена: (config)# vtp domain litladmin
  4. Почему VLAN-ы не распространились с коммутатора SW3 на коммутатор SW2?
    По той же самой причине (см. пункт 3).
  5. Что произойдёт с VLAN 30 на устройстве SW3, когда все проблемы в сети будут решены?
    Все настройки VLAN на SW3 будут утрачены, так как ревизия VTP меньше, чем ревизия на SW1. Чтобы настройки не были утрачены, нужно или перевести режим VTP в Transparent или поднять ревизию выше, чем у SW1 (но тогда затёрты будут настройки на SW1).